Ad Serving Outage Related to AWS Outage

Incident Report for LiveIntent

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 20:22 UTC

Investigating

Ad Serving is severely impacted due to the AWS outage. We are working with AWS to resolve the issue and resume ad serving. Direct Sold, House, and Exchange are all impacted.
Posted Oct 20, 2025 - 15:37 UTC
This incident affected: Ad Serving (Component #1).